The scenario is :IP Addressing :
--------------------
R1 - s0/0 = 10.0.0.1/8 ; lo1 = 1.0.0.1/8
R2 - s0/0 = 10.0.0.2/8 ; lo1 = 2.0.0.2/8
R3 - s0/0 = 10.0.0.3/8 ; lo1 = 3.0.0.3/8
Let's configure rip and default-information originate on R1
--------------------------------------------------------------------------
router rip
network 1.0.0.0
network 10.0.0.0
default-information originate
distribute-list prefix DEFAULT out
!
ip prefix-list DEFAULT seq 5 permit 0.0.0.0/0
Let's configure rip on R2 and enable ip split-horizon on R2's s0/0
---------------------------------------------------------------------------------
router rip
network 2.0.0.0
network 10.0.0.0
!
interface Serial0/0
ip address 10.0.0.2 255.0.0.0
encapsulation frame-relay
ip split-horizon
serial restart-delay 0
frame-relay map ip 10.0.0.1 201 broadcast
frame-relay map ip 10.0.0.3 201
no frame-relay inverse-arp
end
Let's configure rip on R3 and enable ip split-horizon on R3's s0/0
-------------------------------------------------------------------------------
router rip
network 3.0.0.0
network 10.0.0.0
!
interface Serial0/0
ip address 10.0.0.3 255.0.0.0
encapsulation frame-relay
ip split-horizon
serial restart-delay 0
frame-relay map ip 10.0.0.1 301 broadcast
frame-relay map ip 10.0.0.2 301
no frame-relay inverse-arp
end
Let's see the results on R1, R2 and R3
R1:
R1#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
C 1.0.0.0/8 is directly connected, Loopback1
R 2.0.0.0/8 [120/1] via 10.0.0.2, 00:00:20, Serial0/0
R 3.0.0.0/8 [120/1] via 10.0.0.3, 00:00:04, Serial0/0
C 10.0.0.0/8 is directly connected, Serial0/0
R1#
R2:
R2#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is 10.0.0.1 to network 0.0.0.0
C 2.0.0.0/8 is directly connected, Loopback1
C 10.0.0.0/8 is directly connected, Serial0/0
R* 0.0.0.0/0 [120/1] via 10.0.0.1, 00:00:18, Serial0/0
R2#
R3:
R3#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is 10.0.0.1 to network 0.0.0.0
C 3.0.0.0/8 is directly connected, Loopback1
C 10.0.0.0/8 is directly connected, Serial0/0
R* 0.0.0.0/0 [120/1] via 10.0.0.1, 00:00:04, Serial0/0
R3#
It's working fine.
Let's play on R2 and R3. What happen if we disable ip split-horizon on R2 and R3?
Yes, It will occur routing loops and we can see on R1.
R1:
So now, we are clear on that we must enable ip split-horizon on R2 and R3. Cool!
But, Let's say if the question ask you something like :
Configure R2 and R3, but don't enable ip split-horizon on R2 and R3 to prevent default routes advertising back to R1. :)
Well! We can configure on R2 and R3 by using ip prefix-list.
R2 and R3
---------------
ip prefix-list NO_DEFAULT seq 5 deny 0.0.0.0/0
ip prefix-list NO_DEFAULT seq 10 permit 0.0.0.0/0 le 32
!
router rip
distribute-list prefix NO_DEFAULT out Serial0/0
Let's see the output on R1, R2 and R3.
R1:R1#ping 2.0.0.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2.0.0.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/25/76 ms
R1#ping 3.0.0.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 3.0.0.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/46/112 ms
R1#
R2:R2#ping 1.0.0.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 1.0.0.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/32/76 ms
R2#ping 3.0.0.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 3.0.0.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/63/140 ms
R2#
R3:R3#ping 1.0.0.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 1.0.0.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/29/80 ms
R3#ping 2.0.0.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2.0.0.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/47/164 ms
R3#
Well Done! :) Enjoy studying!
No comments:
Post a Comment